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OverviewOverview
Windows XP Now Out for Four Years

New, Upgraded and Even Experienced Users Still Asking:
Where is … ?
How do I …?

This Seminar aggregates Interesting Discussions from:
SCSCC Internet SIG
SCSCC Kaffee Klatch
SCSCC Ask The Experts
Computer Industry Magazines and Web Sites
Fred Langa Langlist Web Site Newsletter
Kim Komando Web Site and Newsletter
Scott Finney Newsletter
Woody’s Windows Watch
Brian Livingston’s Windows Secrets Newsletter
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Windows XP Windows XP -- Key EnhancementsKey Enhancements

Rock solid Windows 2000 OS Kernel.
No underlying native 16-bit DOS.
New Technology File System (NTFS)
Multiple user accounts with separate preferences.
New “Luna” look and feel.
Native CD-R burning support (Roxio lite).
Internet Explorer 6 / Outlook Express 6.
Remote Assistance and Remote Desktop (Pro only).
Improved Support for Wireless Networking (SP1 and later).
USB 2 Support (SP1 and later).
Security Center (SP2 and later).
Improved Windows Firewall (SP2 and later).
Many, many security hot fixes (SP2 and later).
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Discussion AreasDiscussion Areas

Some Good Web Sites
Bug Fixes and Service Pack 2
Customizing Windows XP
Security
Performance



3

TNB 04-28-05 Windows XP Tips & Tricks

Some Good Web Sites (1)Some Good Web Sites (1)
MS Win XP Home http://microsoft.com/windowsxp
Belarc Advisor http://belarc.com/free_download.html
SCSCC Handouts http://www.scscc.com/handouts/
Black Viper http://www.blkviper.com/
Download.com http://download.com
Gibson Research http://grc.com
Major Geeks http://www.majorgeeks.com
Fred Langa http://www.langa.com/
Karenware http://www.karenware.com/
Kim Komando http://www.komando.com/
Extreme Tech http://www.extremetech.com/
PC Magazine http://www.pcmag.com/
PC Pitstop http://www.pcpitstop.com/
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Some Good Web Sites (2)Some Good Web Sites (2)
System Internals http://www.sysinternals.com/
Windows IT Pro http://www.windowsitpro.com/
Win Guides http://www.winguides.com/
ZD Net http://www.zdnet.com/
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Bug Fixes Bug Fixes –– Windows Update (1)Windows Update (1)

Windows XP can connect to MS Windows Update site
New critical fixes posted about once a month
Fixes for all versions of Windows, IE and OE
Can be fully automatic, prompted (best) or disabled

Broader range of fixes available on-line
Connect to Windows Update
Review Critical and Recommended Fixes
Select those you want
Download and Install
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Bug Fixes Bug Fixes –– Windows Update (2)Windows Update (2)

Automatic Critical Fix Notification:
Recommend DO NOT use fully automatic mode.
Safest setting is:

“Notify before downloading, “Notify before installing”

Configure this in:
Start > Control Panel > System > Automatic Updates

Manual Check for Non-Critical Updates:
Click:

Start > Windows Update (if it’s present)

Otherwise click:
Start > All Programs > Windows Update
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Installing Service Pack 2Installing Service Pack 2

Strongly recommended!

Advise against using Windows Update.
75MB to 220MB download – takes day son dial-up

Use “Full SP2 Install” on CD
Either MS free CD (in lab)
Or Tom Burt’s Windows Updates CD (CD77 in lab).

Simply insert MS CD (autostarts)
Or insert CD 77 and double-click on the SP2 setup

Runs about ½ hour to 45 minutes
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Customizing Task BarCustomizing Task Bar

Right click on the Task Bar to open a context menu.
Toolbar choices:

Quick Launch (recommended)
New Toolbar (Custom personal links)
Language
Desktop

Lock The Taskbar (prevents changes)
Properties > Taskbar tab

AutoHide
Keep Taskbar on top
Show the clock
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Customizing Start MenuCustomizing Start Menu

Right click on the Task Bar to open a context menu.
Or … Control Panel > Task Bar and Start Menu.
Properties > Start Menu tab

Win XP style vs Classic

Click the Customize button > General Tab
Large vs Small icons
Number of programs to remember on Start Menu
Show IE and Outlook on Start menu

Click the Customize button > Advanced Tab
Open submenus when mouse hovers
Highlight newly installed programs
Start menu items options list
Recent Documents options
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Setting Up Quick Launch ItemsSetting Up Quick Launch Items

To Add a new Quick Launch Item:

Create a shortcut on the desktop to the desired program.

Right click on the desktop.

Select New > Shortcut.

Type or browse to the desired program.

Assign a name and click Finish.

Drag the shortcut onto the Quick Launch toolbar.

To Remove a Quick Launch Item:

Right click on the item to be removed.

Select Delete.

Click OK.
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Customizing The DesktopCustomizing The Desktop

Click Control Panel > Display
Or Right click on the desktop and click Properties
Themes tab allows large scale changing of look and feel

Main choices: Windows XP or Windows Classic (98)

Desktop tab:
Background (Wallpaper)
Customize Desktop Button

Desktop Icons
Desktop Cleanup options

Screen Saver tab (screen saver and power settings)
Appearance Tab (customize your theme)

Effects button (Clear Type font smoothing)
Advanced button (detailed control of colors and effects)
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MS Tweak UI Power ToyMS Tweak UI Power Toy

Download from:

http://www.microsoft.com/windowsxp/pro/downloads/powertoys.asp

Win XP version runs from the Start menu.

Excellent tool for customizing settings that are difficult to find.

MS says “Not supported”.
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Customizing Windows Explorer (1)Customizing Windows Explorer (1)

Right click Start, then select Explorer, or Windows key + E

View Menu:

Toolbars

Status Bar (recommend on)

Explorer Bar (Recommend Folders be selected)

Specific view (Thumbnails, Tiles, Icons, List, Details)

Arrange icons by …

Choose Details
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Customizing Windows Explorer (2)Customizing Windows Explorer (2)

Tools > Folder Options > General Tab

Tasks:

Show common tasks (Win XP style)

Use Windows classic folders

Browse folders:

Open each folder in same window

Open each folder in its own window

Click Items as follows:

Single click to open

Double click to open



9

TNB 04-28-05 Windows XP Tips & Tricks

Customizing Windows Explorer (3)Customizing Windows Explorer (3)

Tools > Folder Options > View Tab

Folder Views:
Apply to all folders (as default)

Reset all folders (to Win XP default)

Advanced settings:

Automatically search for network folders and printers (better unchecked)

Show hidden files and folders (recommend selected)

Hide extensions for known file types (better unchecked)

Hide protected operating system files (better unchecked)

Desktop Shortcut to Explore a specific drive or folder

Right click on the desktop > new Shortcut

Explorer /e,/root,[drive:][\folder name or path]

E.g. Explorer /e,/root,C:\ (opens Windows Explorer at C:\)
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Bio Break
10 Minutes
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Customizing Internet Explorer (1)Customizing Internet Explorer (1)

Click Start > Control Panel > Internet Options

Or Open Internet Explorer and click Tools > Internet Options

General Tab:

Home page (first page to display when IE launches)

Temporary Internet Files > Settings (recommend 10MB cache size)

Cookies

History

Colors button

Fonts button

Accessibility (options for sight impaired) button
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Customizing Internet Explorer (2)Customizing Internet Explorer (2)

Security Tab:

Security Zones:

Internet, Local Intranet, Trusted Sites, Restricted Sites

Security Level for each zone:

Default levels (High, Medium, Medium low, Low)

Custom levels Settings dialog

Many choices – e.g.

Active X Controls

Java Applets

Downloads

Launching programs and files

Scripting



11

TNB 04-28-05 Windows XP Tips & Tricks

Customizing Internet Explorer (3)Customizing Internet Explorer (3)
Privacy Tab (Cookie policies):

Default (Block All, High, Medium High, …)

Advanced (custom settings)

Content Tab

(Content, Certificates, Personal Information)

Programs Tab (select programs for)

HTML Editor (Notepad.exe)

E-mail program (Outlook or Outlook Express)

Newsgroups (Outlook or Outlook Express)

Internet call (NetMeeting)

Calendar (Outlook)

Contact List (Outlook)
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Customizing Internet Explorer (4)Customizing Internet Explorer (4)

Advanced Tab (many settings):

Accessibility

Browsing

Disable script debugging,  Underline links, …

Java (Sun – if JRE is installed)

Microsoft VM

Multimedia

Show Pictures, Play Music, Play Videos, Play Animations, …

Printing

Search

Security
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Customizing System (1)Customizing System (1)

Click Start > Control Panel > System
General Tab – information about your PC and OS
Computer Name tab

Network ID button (invokes wizard for joining a Domain)
Change button (allows changing PC’s network name, workgroup)

Hardware tab
Add Hardware Wizard button (invokes the wizard)
Device Manager button (Opens the Device Manager dialog)
Hardware profiles (mainly for laptops – docked, undocked)

System Restore tab (settings for System Restore function)
Automatic Updates tab (settings for automatic  Windows Update)
Remote tab (settings for Remote Assistance and Remote Desktop)
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Customizing System (2)Customizing System (2)

Click Start > Control Panel > System >Advanced Tab
Performance settings button

Visual Effects
Let Windows choose, Best appearance, Best performance, Custom

Advanced (normally no need to change these)
Processor scheduling, memory usage, Virtual memory

User Profiles settings button (settings for each user account)
System Startup, Failure and Debugging settings button

Default OS to start, timing
System failure actions

Environment Variables button
Edit environment variables for user’s account and for system

Error Reporting button
Dialog to control how errors are handled and reported
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Adding Adding ““Safe ModeSafe Mode”” Choice To Choice To BootupBootup

Can click Start > Control Panel > System > Startup and Recovery
or can use Notepad to edit the hidden C:\Boot.ini file
or can use the MSConfig program

Under [Operating Systems] add the following line of text :

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP 
Professional Safe Mode" /fastdetect /safeboot:minimal /sos /bootlog

Also adjust the Timeout value to be about 10 seconds.

Now when Win XP boots, you will see a menu with two choices:

Microsoft Windows XP Professional (default)

Microsoft Windows XP Professional Safe Mode

You can scroll to the Safe Mode entry when desired.
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Win XP Setup Boot DiskettesWin XP Setup Boot Diskettes

Good to have for unexpected emergency.

Win XP Setup boot disks are available (6 diskettes).
Windows XP Home:

http://www.microsoft.com/downloads/release.asp?ReleaseID=33290&a
rea=search&ordinal=47

Windows XP Professional:
http://www.microsoft.com/downloads/release.asp?ReleaseID=33291&a
rea=search&ordinal=70

Faster to boot from CD ROM if your PC’s BIOS supports it.
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Performance TweaksPerformance Tweaks

Minimize Temporary Internet Files Cache Size to 10 MB
Start > Control panel > Internet Options

Get rid of unneeded Startup programs
Start > Run > MSConfig
Look in Services tab and Startup tab

Minimize unneeded graphical enhancements
Use TweakUI (see next slide) or …
Start > Control panel > Display > Appearance
Start > Control Panel > System > Advanced > Visual Effects

Adjust CPU and virtual memory Settings
Start > Control Panel > System > Advanced > Advanced
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Computer ManagementComputer Management

Click Start > Control Panel > Administrative Tools > Computer Management

System Tools > Shared Folders:
View and manage shared folders

Note share names ending with $ are hidden (good practice)

Advisable to remove “administrative shares” (e.g. C$)

Disk Defragmenter (optimizes file organization on hard disk)

XP version is safe and reliable. Use occasionally to keep performance up.

Storage > Disk Management:

View and manage drives and partitions (a graphical FDISK).

Can change drive letters assigned to hard drives (except boot drive) and CD Drives.

Services and Applications > Indexing Service > System > Directories
Manage the indexing service for drives and folders (best turned off).
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Configuring Printers and FaxesConfiguring Printers and Faxes

Click Start > Printers and Faxes
To Add a printer, click on “Add a printer”.

Follow the steps in the wizard.

To edit printer properties, click on the printer of interest
then click on “Set printer properties”.
Printer-specific multi-tabbed dialog will open.

To adjust printing preferences, click on the printer of  interest
then click on “Select printing preferences”.
Printer-specific multi-tabbed dialog will open.

For FAX printer driver, you need a FAX / Data modem.
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User AccountsUser Accounts

Click Start > Control Panel > User Accounts
Security considerations:

May want to create separate administrator account.
May want to have limited accounts for visitors.
May want to have separate accounts (his / hers) if sharing a PC.
Can use Tweak UI to set up one account as “automatic login”.
Recommend using passwords on any Administrator account.

Options to change:
Name
Password (including remove)
Picture (any image file)
Account type (Computer Administrator or Limited)
.Net passport
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Customizing the Customizing the ““Send ToSend To”” MenuMenu

Each Win XP user account has its own “Send To” menu.

“Send To” menu is defined by a folder in the user’s personal folder.

To add  a “Send To” target, add a shortcut to the “Send To” folder.

Steps:

Create the shortcut on the Desktop (can point to a program or folder).

Start the Windows Explorer.

Navigate to C:\Documents and Settings\<user name>\Desktop.

Move the shortcut from the Desktop folder to the Send To folder.

Now using Explorer, right click on a file.

Select the Send To item on the resultant context menu.

Notice your new shortcut as a target.
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Help and Support CenterHelp and Support Center

Click Start > Help and Support
Several hot link areas on the Help and Support Window:

Search
Local help system + MS Knowledge Base.

Pick a Help Topic

Ask for Assistance
Initiates Remote Assistance.
Links to Microsoft Newsgroups.

Pick a Task – Invokes various wizards

Did You Know? – Breaking MS news
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Your Your ““How ToHow To””
Questions and AnswersQuestions and Answers


